New Posts New Posts RSS Feed: Deploying Breeze
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

Deploying Breeze

 Post Reply Post Reply
bizcad View Drop Down

Joined: 24-Sep-2012
Location: Carlsbad, CA
Posts: 2
Post Options Post Options   Quote bizcad Quote  Post ReplyReply Direct Link To This Post Topic: Deploying Breeze
    Posted: 24-Sep-2012 at 3:48pm
1.  I downloaded breeze-runtime-plus-0.55 (the ToDo app) and compiled on my local machine with VS2012 RTM.  It worked out of the box running in IISExpress.
2.  I then changed the Connnection String in Web.Config to point to a real SqlServer 2005 located on our network.  It worked.
3.  I then Published the app to a Windows 2012 running in a VM on the network as an application running on port 80.
*Publish Method: WebDeploy
*Service URL: (the ip address of the VM)  for some reason DNS did not work with the VM name.
*Site/application: Default Web Site/ToDo
*Destination URL:
*UserName: mydomain\nstein
*I used my password - I am a domain admin so I did not think there would be a problem with security.
The connection validated.
On the next dialog, I used the connection string from Web.Config.
On the last dialog, the Preview looked ok, so I published.
4.  I then went to an IE9 and hit the application.  The screen was gray with no ToDo list.  An F12 -> Network capture and refresh showed that I was getting a 404 with main.js.  So I went to the Server and checked to make sure that main.js was there and it was.  The 404 was looking for main.js in when the app was pointing to
5.  I got the Sales Rep Derick on the line and he pulled in a Developer who explained that Breeze expects the app to be from the base.  He helped me delete the old app and reinstall as a new Website on port 8080.  Now when I hit, the app comes up.  I do not like it.  I would prefer that I could run from within the Default Web Site.  But at least I know the problem exists.
6.  So I went back to VS and added a ~/ to the front of the script tag to see if that would work. 

<script data-main="Scripts/main" src="@Url.Content("~/Scripts/lib/require.js")"></script>


<script data-main="~/Scripts/main" src="@Url.Content("~/Scripts/lib/require.js")"></script>

It was a breaking change.  Now when I run from F5, the app breaks at the third line of dataservice.js

core = breeze.core,It continues to break there even if I remove the ~/.  They went off to see if they could repeat the problem and they were able to do so.  I am sure a fix will be in the next build. 

Nick Stein
Back to Top
JoshO View Drop Down

Joined: 09-May-2007
Location: United States
Posts: 86
Post Options Post Options   Quote JoshO Quote  Post ReplyReply Direct Link To This Post Posted: 24-Sep-2012 at 4:48pm
I'm the "IT guy" and I don't code so I can't explain why things in Visual Studio happen the way they happen...but I do know that the changes you made to the index.cshtml file did produce an error during Debug in IIS Express which did not correct itself when you reverted back to this:
 <script data-main="Scripts/main" src="@Url.Content("~/Scripts/lib/require.js")"></script>
I was able to reproduce everthing you saw and was also able to correct the problem in Visual Studio by right-clicking the ToDo solution and performing a "Clean Solution" first and then a build. This was the only method that worked and don't ask me why ;`)
As to deploying the app in a nested application folder under "Default Web Site" make the following changes to the index.cshtml file assuming the app folder is named "ToDo" (in IIS only not VS!!) --
<!DOCTYPE html>
        <meta charset="utf-8" />
        <meta name="viewport" content="width=device-width" />
        <title>Breeze Todos</title>
        <link rel="stylesheet" href="@Url.Content("/ToDo/Content/reset.css")"/>
        <link rel="stylesheet" href="@Url.Content("/ToDo/Content/toastr.css")"/>
        <link rel="stylesheet" href="@Url.Content("/ToDo/Content/toastr-responsive.css")"/>
        <link rel="stylesheet" href="@Url.Content("/ToDo/Content/todo.css")"/>
        <div id="applicationHost"></div>
        <script src="@Url.Content("Scripts/lib/jquery-1.8.0.min.js")"></script>
        <script src="@Url.Content("Scripts/lib/knockout-2.1.0.js")"></script>
        <script src="@Url.Content("Scripts/lib/q.js")"></script>
        <script src="@Url.Content("Scripts/lib/toastr.js")"></script>
        <script data-main="Scripts/main" src="@Url.Content("Scripts/lib/require.js")"></script>
The tricky part is the css files are relative to the root of the site but not the Scripts which are relative to the application root.
Stuff like this keeps me employed!

Edited by JoshO - 24-Sep-2012 at 5:15pm
Back to Top
bizcad View Drop Down

Joined: 24-Sep-2012
Location: Carlsbad, CA
Posts: 2
Post Options Post Options   Quote bizcad Quote  Post ReplyReply Direct Link To This Post Posted: 28-Sep-2012 at 2:15pm
I downloaded the newest version of everything IdeaBlade-Breeze-4c7684d today at home on my Windows 8 Machine running VS2012 Premium. After unzipping the file in my Downloads Folder, I copied it into a new folder in Visual Studio 2012\Projects and used Windows Explorer to unset the folder as read only. I then changed permissions, adding Everyone, and giving full control.

1. I opened the ToDo app in VS.
2. Made sure the Allow NuGet to Download was checked and Rebuilt the Project.
3. F5 launched the app and I did some minor testing. Everything worked.
4. The Todo.sdf was created in the AppData folder and I was able to look at the database.

Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down