Print Page | Close Window

nuget package dependency

Printed From: IdeaBlade
Category: Cocktail
Forum Name: Community Forum
Forum Discription: A professional application framework using Caliburn.Micro and DevForce
URL: http://www.ideablade.com/forum/forum_posts.asp?TID=3907
Printed Date: 21-Oct-2020 at 7:39pm


Topic: nuget package dependency
Posted By: kdev
Subject: nuget package dependency
Date Posted: 20-Jan-2013 at 8:05am
Hi,

Is it possible in the next Cocktail package to not strictly ask for a specific version of caliburn ? that way everyone can benefits of their futur services release without waiting a update of cocktail.



Replies:
Posted By: mgood
Date Posted: 21-Jan-2013 at 12:51am
Cocktail is built with a specific version of Caliburn.Micro and has a hard reference to that version. For WPF this can be worked around with assembly binding redirects, but not on the other platforms. More importantly, we test Cocktail against the specific version and allowing for more recent versions could increase our support burden, so we have to carefully consider the implications. Are you developing for WPF, Silverlight or Windows 8 Store?


Posted By: kdev
Date Posted: 21-Jan-2013 at 1:20pm
Silverlight



Posted By: mgood
Date Posted: 22-Jan-2013 at 7:16am
In that case it's not even possible, because Silverlight doesn't support assembly binding redirection.


Posted By: KitKat
Date Posted: 07-Feb-2013 at 11:53am
How would you do this with WPF, as Cocktail is looking for 1.4, but CM 1.4.1 resolves some issues for WPF and .NET 4.5

Updating 'Caliburn.Micro' from version '1.4' to '1.4.1' in project 'SSBWageTaxRecalculation'.
Update-Package : Updating 'Caliburn.Micro 1.4' to 'Caliburn.Micro 1.4.1' failed. Unable to find a version of 'IdeaBlade.
Cocktail' that is compatible with 'Caliburn.Micro 1.4.1'.
At line:1 char:15
+ Update-Package <<<<  Caliburn.Micro
    + CategoryInfo          : NotSpecified: (:) [Update-Package], Exception
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.UpdatePackageCommand


Posted By: mgood
Date Posted: 07-Feb-2013 at 12:46pm
KitKat,
You can't do it with the current NuGet package, because the dependency requires 1.4. I can relax this dependency in the future for WPF to allow newer versions. In the meantime if you really need 1.4.1 you can reference the CM 1.4.1 assembly directly and then add assembly binding redirection manually to your app.config, so that Cocktail is satisfied with 1.4.1. No guarantee that Cocktail will work with 1.4.1. I haven't tested it yet.
 
http://msdn.microsoft.com/en-us/library/2fc472t2%28v=vs.110%29.aspx - http://msdn.microsoft.com/en-us/library/2fc472t2(v=vs.110).aspx
 


Posted By: KitKat
Date Posted: 08-Feb-2013 at 7:12am
Thank you for the reply.  I would think it reasonable to allow any minor version changes while still documenting that it is only tested for a specific version.  

I have found it reasonable to assume that is is likely (I dont assume a guarantee) that minor versions have very few if any breaking changes.

Thanks again,
Katerina


Posted By: mgood
Date Posted: 26-Feb-2013 at 7:05pm
Just a quick update. The recently released Cocktail v2.2.1 adds official support for Caliburn.Micro v1.4.1 and for WPF, CM can now be updated independently of Cocktail.


Posted By: gregweb
Date Posted: 27-Feb-2013 at 10:14am
Great, just updated.


Posted By: cypher
Date Posted: 12-Jun-2013 at 5:41am
jep, i also love this feature. thanks. 



Print Page | Close Window