Print Page | Close Window

Visual studio 2013

Printed From: IdeaBlade
Category: Cocktail
Forum Name: Community Forum
Forum Discription: A professional application framework using Caliburn.Micro and DevForce
URL: http://www.ideablade.com/forum/forum_posts.asp?TID=4609
Printed Date: 12-Nov-2019 at 2:18am


Topic: Visual studio 2013
Posted By: jkattestaart
Subject: Visual studio 2013
Date Posted: 25-Nov-2013 at 11:34pm
This weekend i tried to start my project in the visual studio 2013 environment. I started with temphire from coctail 2.4.3.
When i loaded the project and restored the packages from nuget.
Postsharp was giving me trouble in domainmodel.sl so i tried to update the posharp to the latest version, but this was a problem for devforce.aop (no compatible version)

What to do....



Replies:
Posted By: mgood
Date Posted: 26-Nov-2013 at 6:56am
Did you follow the steps documented here to properly install and configure PostSharp 3.0? Also see the additional notes at the bottom regarding the assembly version. 

http://drc.ideablade.com/devforce-2012/bin/view/Documentation/postsharp3 - http://drc.ideablade.com/devforce-2012/bin/view/Documentation/postsharp3

Also, make sure the PostSharp Extension is properly installed in Visual Studio. PostSharp 3.0 does not work anymore without the extension installed. 

http://visualstudiogallery.msdn.microsoft.com/a058d5d3-e654-43f8-a308-c3bdfdd0be4a - http://visualstudiogallery.msdn.microsoft.com/a058d5d3-e654-43f8-a308-c3bdfdd0be4a


Posted By: jkattestaart
Date Posted: 26-Nov-2013 at 2:11pm
Apperently Kim posted a solution on the devforce forum.
DevForce 7.2.2 / PostSharp 3.0.39.x

Somehow i still get errors... on the DomainModel.SL en Security.SL
Tomorrow i will give it another try



Print Page | Close Window